Page 1 of 1

Port 80 Not Working

Posted: Thu Jul 22, 2021 8:57 pm
by coeyflyer

I installed MAMP 6.4 on a new Mac. I have the document root folder pointing to an ssd external drive directory that is Shared. I am and will be mostly working with Wordpress web sites for the time being. I am having an issue in that everything works fine when using port 8888 for apache, but once I change port to 80, I get the following errors:

Forbidden 403: You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe

Apache Log:
[core:crit] [pid 82015] (1)Operation not permitted: [client ::1:62812] AH00529: /Volumes/.../.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/Volumes/.../' is executable

I have gone through the http file and made sure my paths are correct. I have played with the rights for each folder and file. I have played with giving MAMP full disk access through Security and Privacy. I have also checked to see if anything else is running on port 80 from the CLI, and the only process running on port 80 is httpd.conf. I have tried other minor things I have found through my searches for a solution. It would appear that the two error messages would point me to a rights/permission issue, but I am confused as to why it works perfectly with port 8888 and then permissions come into play only when using port 80. I assume that there may be a reason beyond my knowledge, which is why I was hoping someone from this forum could point me in the right direction.

Thank you for any suggestions you may have...


Re: Port 80 Not Working

Posted: Tue Jul 27, 2021 3:21 pm
by mampsupportmod
So as a test did you try port 80 and point your host to your local disk? Also, do you actually have a .htaccess file where it's looking? I don't know if wordpress creates it by default, usually you have to rename it to .htaccess after you want to change things.

Re: Port 80 Not Working

Posted: Tue Jul 27, 2021 7:17 pm
by coeyflyer
Yes, I did try port 80 on local disk. I used the default htdocs folder and also created a sites folder in the Documents directory and both port 80 and 8888 worked just fine on local disk.

When I first setup MAMP I installed Wordpress while Apache was assigned to port 8888–which does setup an .htaccess file. So yes one is there. I also tried creating an .htaccess file and left blank which did not work. I tried creating a new Wordpress site on external drive with Apache set to port 80 and I just get a blank page 403 forbidden, no Apache log errors, but once I set port to 8888 it performs as expected.

It’s very bizarre… I could accept it if nothing worked from external drive but the fact that only port 80 on external drive is an issue is perplexing. In all honestly, I can find alternatives as a work around, but it bothers me that there is no apparent reason for it to not work…