MAMP won’t start up anymore

All MAMP discussions around troubleshooting and anything related to MAMP. Be as detailed as possible here when posting an issue.
Post Reply
Posts: 1
Joined: Wed Apr 24, 2024 12:13 pm

MAMP won’t start up anymore

Post by Zuff »

Hi there, I wonder if anyone could point me in the right direction. I have MAMP 4.2.0 on a Windows OS, it’s something I downloaded in 2020.
Everything was working fine, until I tried methods to change my PHP. I have 7.4.1 PHP.

My PC is a Windows 10 operating system. I watched a tutorial for XAMPP and I tried something which didn’t work, so I deleted what I tried to do, but now my MAMP will not start up.

What I tried to do is, I downloaded MAMP 5.0.5 on to another PC. I copied the (Apache) and the (PHP) folder from the MAMP 5.0.5, location OS (C), MAMP, Bin.

On my original PC with MAMP 4.2.0, location OS (C), MAMP, Bin. I renamed the Apache and PHP folder and added an underscore to the existing name of the Apache and PHP folder i.e. so it doesn’t function and becomes undetected.

I copy and pasted the MAMP 5.0.5 Apache and PHP folder into the PC with the MAMP 4.2.0. After in MAMP 4.2.0 in preferences the PHP showed version 8.0.1. So I tried to start MAMP, but it wouldn’t start.

Immediately I deleted the Apache and PHP folder that came from MAMP 5.0.5, and I renamed my original Apache and PHP folder by removing the added underscore.

Now my MAMP 4.2.0 will not start up at all i.e. Apache Server & MySQL Server will not start.
Please can anyone guide me on what I can do to restore this.

Or can someone advise me on how I can transfer my MAMP 4.2.0 folders i.e. the ones needed to make my database open up and work in the new MAMP 5.0.5 on the other PC. Remember I can’t access the MAMP database on the 4.2.0.

The reason I was trying to change my PHP, is because the 7.4.1 PHP didn’t let me migrate a website that was over 2GB, and I got an error message saying 7.4.1 does not support 64bit values. The plugin I was using i.e. All In One WP Migration Unlimited by servmask popped up a message saying, Your PHP is 32 bit. In order to import your file, please change your PHP version to 64bit and try again.

Also, I couldn’t find anything as tutorials regarding Windows operating system and how to update MAMP or upgrade PHP. There are tutorials but they seem to be all Mac i.e. Apple related.

Kind Regards Zuff
Post Reply