Registrations: Open.
Please register here.

MAMP PRO 6.0.1 - Enable HTTP2 using Apache

All MAMP discussions around troubleshooting and anything related to MAMP. Be as detailed as possible here when posting an issue.
Post Reply
User avatar
mampsupportmod
Site Admin
Posts: 67
Joined: Wed Jan 20, 2021 3:06 am

MAMP PRO 6.0.1 - Enable HTTP2 using Apache

Post by mampsupportmod »

I just installed the latest version of MAMP PRO 6.0.1 and want to configure one of my hosts to use the HTTP2 protocol and not HTTP/1.1. The 'http2_module' is enabled (by default). My host is using a SSL file. I'm accessing it on HTTPS. I've added 'Protocols h2c' to the 'Additional Parameters' section of the host configuration. Restarted. But... according to my browser's developer tools, they're still 1.1 requests, not 2.0...

Did anyone try this yet? Any clues on what I might be missing?
User avatar
mampsupportmod
Site Admin
Posts: 67
Joined: Wed Jan 20, 2021 3:06 am

Re: MAMP PRO 6.0.1 - Enable HTTP2 using Apache

Post by mampsupportmod »

MAMP PRO Version 6 includes mod_http2 but HTTP2 is still not supported with Apache from what I can see. With the module on and including "Protocols h2 h2c http/1.1" in the config it still doesn't work and the reason is because Apache is using the mpm_prefork module as shown in the error log when starting the server (http2 logging has to be on to show this):

AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.

MAMP Pro will have to use mpm_event instead of mpm_prefork and allow us to use PHP-FPM before HTTP2 will work. We can set our PHP Mode to CGI instead of Module and use Nginx for a specific host on port 443 but HTTP2 still doesn't work so even with version 6 we're still behind the times!
Post Reply