Registrations: Open.
Please register here.

500 Internal Server Error after MAMP upgrade from 5.5 to 6

All MAMP discussions around troubleshooting and anything related to MAMP. Be as detailed as possible here when posting an issue.
Post Reply
User avatar
mampsupportmod
Site Admin
Posts: 68
Joined: Wed Jan 20, 2021 3:06 am

500 Internal Server Error after MAMP upgrade from 5.5 to 6

Post by mampsupportmod »

Since upgrading from MAMP 5.5 to 6.0.1 I am having intermittent "Internal Server Error" responses with a 500 return code.

These seem to be when the server has a lot of work to do so after clearing the cache for example or clearing the compiled content, when I refresh the same page then it completes without error. I have checked the apache, PHP and MySQL logs and there are no errors corresponding with the times the issues occur.

I have my php.ini set to use "unlimited" memory (memory_limit = -1) so that is not the limitation, but it feels like I am hitting some other limitation which is causing an issue without throwing an error, has anybody else come across this or know of a way to increase the logging in MAMP so I can debug this issue, because at the moment I am stumped.

For reference I am running on Mac Catalina 10.15.7 and the site I am running is a Magento 2.3 build running on PHP 7.2.33 with Apache.

Loom video showing the issue, 500 on first attempt, page loads successfully on second attempt, the same can pretty much be repeated on all pages across the site after a cache clean.
User avatar
mampsupportmod
Site Admin
Posts: 68
Joined: Wed Jan 20, 2021 3:06 am

Re: 500 Internal Server Error after MAMP upgrade from 5.5 to 6

Post by mampsupportmod »

When I was using PHP 7.4.9 CGI mode, I too got random 500 errors. However, I was only using this mode briefly. I switched back to module mode and it's been fine without 500 errors for over a month. My config is below

memory_limit = 512M
max_input_time = 300
max_execution_time = 300


I had the same issue with CGI mode on Apache. I found that the update had removed my previous timeout settings and I had to re-enter them according to this answer: https://stackoverflow.com/a/24976009/2377238 , particularly commenting out

Code: Select all

MAMP_FastCgiServer_MAMP
and adding

Code: Select all

FastCgiServer /Applications/MAMP/fcgi-bin/php7.4.9.fcgi -idle-timeout 3600
(for all versions you use). Then you need to restart the server.
Post Reply