HTTP 500 Error access phpMyAdmin on Mac Monterey

All MAMP discussions around troubleshooting and anything related to MAMP. Be as detailed as possible here when posting an issue.
Post Reply
trstaley
Posts: 2
Joined: Wed Jul 27, 2022 12:53 pm

HTTP 500 Error access phpMyAdmin on Mac Monterey

Post by trstaley »

I bought a a new iMac and migrated my old iMac running Mohave OS to my new iMac which is running Monterey OS. My previous iMac had a fully functional MAMP Pro install.

My httpd.conf file is in the Library/appsolute/MAMP PRO/conf directory and set listen on port 80.

After migrating, I can launch MAMP Pro. Apache is running and all my databases are displayed. I am also able to launch my php app. However the app is not connecting to the database.

Using the terminal I can see that the databases are there and I can connect to a database and query tables with no issue.

When I go to Webstart in MAMP Pro and then attempt to launch phpMyAdmin, I get the following error:

This page isn’t working
localhost is currently unable to handle this request.
HTTP ERROR 500

Anyone have any suggestions for how to correct this issue?
mampsupportmod
Site Admin
Posts: 140
Joined: Wed Jan 20, 2021 3:06 am

Re: HTTP 500 Error access phpMyAdmin on Mac Monterey

Post by mampsupportmod »

Please share Apache/PHP/MySQL logs after getting the 500 error
MAMP Support Forums is an unofficial support forum covering MAMP & MAMP Pro solution stacks.
trstaley
Posts: 2
Joined: Wed Jul 27, 2022 12:53 pm

Re: HTTP 500 Error access phpMyAdmin on Mac Monterey

Post by trstaley »

I apologize for not doing so.

[28-Jul-2022 09:06:23 America/New_York] PHP Parse error: syntax error, unexpected 'use' (T_USE) in /Library/Application Support/appsolute/MAMP PRO/phpMyAdmin/index.php on line 11

I found the issue and it was a mistyped statement in the php file. My assumption was that it had to do with something else, and I missed checking the php error log.

Thank you for asking to attach the log files, as this caused me to re-look at them.
Post Reply