1. jaladuvar
  2. MAMP - General Discussion
  3. Tuesday, 15 October 2019

Hello,

I'm fighting for finding the right settings to get garradin (there it is explained and can be loaded - it's all in french I'm afraid) working with MAMP.

Since release 0-9.3 to install this on a local server it is required that it is attached to a virtual host.

"Avant d'installer, vérifiez que votre hébergeur dispose bien de PHP dans une version supérieure ou égale à 5.6 et de SQLite3.

  • Télécharger la dernière version : téléchargement Garradin (prendre le fichier .tar.bz2)
  • Décompresser le fichier dans un répertoire accessible au serveur web
  • Positionner un virtual host (aussi appelé "sous-domaine") sur le répertoire www/ du répertoire de Garradin
  • Se rendre avec son navigateur sur le virtual host de Garradin pour terminer l'installation"

If I simply point to the MAMP set address it  doesn't work, I've been trying all recipes to create virtual hosts in MAMP environment and they all fail.

The help forum for Garradin never came with an answer, 

 

I'm maintaining Garradin for a retiree association and being able to test things in running the app in MAMP PRO is very useful.

Can anyone help ? Thanks..



Accepted Answer Pending Moderation
0
Votes
Undo

I'm not familiar with Garradin, but all you should need to do is put Garradin in a folder and create your MAMP Pro host and point to that document root.

 

Do you have a link to the Garradin kickstart or installer file? I'll take a look

  1. more than a month ago
  2. MAMP - General Discussion
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo

Normally I put any test site as you say, and I used to do this for previous releases of Garradin, and it worked,  but since 0-9.3 there is this « new » requirement and the launch fails...

The link is on the page that opens in the link in my first post here it is lLoad Garradin

Thanks for having a look

  1. more than a month ago
  2. MAMP - General Discussion
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo

Normally I put any test site as you say, and I used to do this for previous releases of Garradin, and it worked,  but since 0-9.3 there is this « new » requirement and the launch fails...

The link is on the page that opens in the link in my first post here it is lLoad Garradin

Thanks for having a look

I'm not sure what I should be seeing but is this what you are?

 

garradin mamps setup

  1. more than a month ago
  2. MAMP - General Discussion
  3. # 3
Accepted Answer Pending Moderation
1
Votes
Undo

The issue is with releases O.9.3 and following.

I can connect to the MAMP site (should point to the www folder of the extracted archive) if I remove .htaccess in this www folder., not very sane but it is likely that this file contains instructions that create the issue..

So, from a very short term point of. view the issue is solved, but not very satisfactory

If you want to have a look, download https://fossil.kd2.org/garradin/uv/garradin-0.9.4.tar.bz2

 

cheers

 

  1. more than a month ago
  2. MAMP - General Discussion
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo

I had a look at the .htaccess file and I commented the second line, it's ok like that..

So issue resolved

Options -MultiViews -Indexes
#DirectoryIndex disabled
DirectoryIndex index.php

# FallbackResource n'est dispo que depuis Apache 2.2.16, soit Debian Wheezy (2013)
# Mais bugue avant Apache 2.4.15, il faut donc bien désactiver le DirectoryIndex
# cf. https://bz.apache.org/bugzilla/show_bug.cgi?id=58292
# et https://serverfault.com/questions/559067/apache-hangs-for-five-seconds-with-fallbackresource-when-accessing

= 2.2.16>
FallbackResource /_route.php

ErrorDocument 404 /_route.php

  1. more than a month ago
  2. MAMP - General Discussion
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!