1. alang
  2. MAMP - Troubleshooting
  3. Tuesday, 21 January 2020

Hello. I have begun receiving the following error messages (below) when attempting to access all of my localhost-based Joomla development sites that are located on the same device that I am trying to access the sites with, (no LAN or secondary devices involved).

In Firefox:  "The connection was reset"

In Chrome:  "This page isn’t working localhost didn’t send any data. ERR_EMPTY_RESPONSE"

Previously, these sites have operated properly. However, after attempting to open them within the MAMP (v. 5.6 and 5.4) environments after a several month hiatus, I am getting these recurring messages. This is true on both the Visitor & Administrator sides of the sites. I was able to update one of the sites after multiple attempts to Joomla v. 3.9.14, with no effect on the error messages. Pages on the visitor side will sometimes load after several attempts, but the administrator side will only load the 'Control Panel' or 'System Information' pages after multiple attempts.

Can anyone offer any direction on what is going wrong and suggestions on how I can fix this? Thanks!



Accepted Answer Pending Moderation
0
Votes
Undo

I am also seeing this error and cannot install Joomla. I see this the in mysql logs:

 

Access denied for user ''@'localhost' (using password: NO)

 

im not even trying to connect. it’s just when i open http://localhost:8888/joomla/installation/index.php

 

It won’t even let me begin installation

 

My WordPress and Grav sites work great. Just not Joomla.

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo

Is this on Mac or Windows? I don't have the latest version (5.4 or 5.6) to test this but will try to. I have many Joomla sites running with MAMP. Does your Console events on Mac reveal anything when you try the same? Did you recently upgrade MAMP and then this has started to happen?

 

Please also post the following details:

 

Your OS and Version:

MAMP Version:

PHP Version:

Joomla Site Version:

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo

Yes, it started with MAMP 5.6. It was working great in MAMP 5.5

 

Your OS and Version: macOS Mojave

MAMP Version: MAMP 5.6

PHP Version: 7.3.9

Joomla Site Version: Joomla 3.9.14

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSuppportMod,

This issue started when I attempted to access multiple localhost development sites prior to upgrading MAMP from v. 5.4 to 5.6. These sites had previously run successfully under v 5.4. (I also just got the same errors when I attempted to run the sites using MAMP v. 5.3) One site I was able after many attempts to upgrade to Joomla v. 3.9.14, the other sites are still running slightly older versions of Joomla, (3.9.x) but I'm not sure which version because I cannot open the Administrator side of the sites. This error started prior to making any change in the server/joomla environment. The details are below:

Device:  Mac machine running Mojave v. 10.14.6

MAMP:  v. 5.6 and 5.4 (5.6 is a new install, 5.4 is several months old and did not previously have a problem)

PHP:  v. 7.4.1

Joomla:  3.9.14

Thanks for any assistance you can provide with this issue!

A.

 

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSupportMod,

Have you been able to make any progress on this error issue? This persistent error message is basically locking me out of any meaningful access to my localhost development sites. Because it is reporting across several Joomla sites, I don't think that it is an error in a particular Joomla installation, but since other users have reported it, I'm wondering how they resolved it, or if you have any suggestions on how it might be resolved. Thanks!

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo

Did you do anything to fix this when you said it didn.t work on MAMP v5.3?

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 6
Accepted Answer Pending Moderation
0
Votes
Undo

I just reverted to MAMP 5.5:

 

https://downloads.mamp.info/MAMP-PRO/releases/5.5/MAMP_MAMP_PRO_5.5.pkg

 

And now Joomla works!

Accepted Answer Pending Moderation
0
Votes
Undo

MAC 10.11.6

Upgrading 5.4 to 5.6

PHP Version: 7.3.9

Joomla 3.9.14

 

all was working fine with mamp 5.4

 

Safari cannot open  « ‎localhost:8888/..... »  the server unexpectedly dropped the connection.

in mysql_err_log  : same problem on all my databases 

Aborted connection 4 to db: 'largspfw_fr' user: 'root' host: 'localhost' (Got an error reading communication packets)

 

 

 

Accepted Answer Pending Moderation
0
Votes
Undo

full mysql_err_log

 

 

2020-01-29T10:03:06.6NZ mysqld_safe Logging to '/Applications/MAMP/logs/mysql_error_log.err'.
2020-01-29T10:03:06.6NZ mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql57
2020-01-29T10:03:06.763225Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2020-01-29T10:03:06.765932Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2020-01-29T10:03:06.776586Z 0 [Note] /Applications/MAMP/Library/bin/mysqld (mysqld 5.7.26) starting as process 649 ...
2020-01-29T10:03:06.818037Z 0 [Warning] Setting lower_case_table_names=2 because file system for /Applications/MAMP/db/mysql57/ is case insensitive
2020-01-29T10:03:06.846135Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2020-01-29T10:03:06.846171Z 0 [Note] InnoDB: Uses event mutexes
2020-01-29T10:03:06.846182Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2020-01-29T10:03:06.846193Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2020-01-29T10:03:06.853427Z 0 [Note] InnoDB: Number of pools: 1
2020-01-29T10:03:06.868414Z 0 [Note] InnoDB: Using CPU crc32 instructions
2020-01-29T10:03:06.870775Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2020-01-29T10:03:06.898414Z 0 [Note] InnoDB: Completed initialization of buffer pool
2020-01-29T10:03:06.927288Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2020-01-29T10:03:07.057780Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2020-01-29T10:03:07.057946Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2020-01-29T10:03:07.192885Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2020-01-29T10:03:07.194377Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2020-01-29T10:03:07.194396Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2020-01-29T10:03:07.194946Z 0 [Note] InnoDB: Waiting for purge to start
2020-01-29T10:03:07.247474Z 0 [Note] InnoDB: 5.7.26 started; log sequence number 992617017
2020-01-29T10:03:07.249481Z 0 [Note] InnoDB: Loading buffer pool(s) from /Applications/MAMP/db/mysql57/ib_buffer_pool
2020-01-29T10:03:07.250736Z 0 [Note] Plugin 'FEDERATED' is disabled.
2020-01-29T10:03:07.276822Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2020-01-29T10:03:07.276883Z 0 [Note] Server hostname (bind-address): '*'; port: 8889
2020-01-29T10:03:07.277421Z 0 [Note] IPv6 is available.
2020-01-29T10:03:07.277480Z 0 [Note] - '::' resolves to '::';
2020-01-29T10:03:07.277629Z 0 [Note] Server socket created on IP: '::'.
2020-01-29T10:03:07.282762Z 0 [Note] InnoDB: Buffer pool(s) load completed at 200129 11:03:07
2020-01-29T10:03:07.368188Z 0 [Note] Event Scheduler: Loaded 0 events
2020-01-29T10:03:07.368478Z 0 [Note] /Applications/MAMP/Library/bin/mysqld: ready for connections.
Version: '5.7.26' socket: '/Applications/MAMP/tmp/mysql/mysql.sock' port: 8889 MySQL Community Server (GPL)
2020-01-29T10:03:26.142037Z 4 [Note] Aborted connection 4 to db: 'largspfw_fr' user: 'root' host: 'localhost' (Got an error reading communication packets)

 

Accepted Answer Pending Moderation
0
Votes
Undo

back to MAMP 5.5  all is working fine

Accepted Answer Pending Moderation
0
Votes
Undo

Disable IPV6 and try again.

Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSupportMod,

Just to follow up, my localhost installations are still misbehaving regardless of the MAMP versions used. I don't think that the problem that cirke was experiencing is necessarily the same one I have been having because the error messages are different.

To answer your previous question to me though, I didn't do anything to fix the problem when I attempted to access the sites via MAMP v. 5.3 because I have no idea how to fix this issue. Any suggestions? Thanks!

Accepted Answer Pending Moderation
0
Votes
Undo

Please try to disable IPV6 in macOS and see if it makes any difference.

Accepted Answer Pending Moderation
0
Votes
Undo

It would be better if you could fix that issue regarding IPV6

 

thanks

Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSupportMod,

I disabled IPv6 as you suggested which did not correct the problem. If anything it made it more difficult to log into the administrator side of the site. Any other suggestions?

I was thinking that perhaps I should try deleting the latest version of MAMP (v. 5.6) and running an earlier version, but I'm not sure how to completely delete an installation of MAMP without also blowing away my sites with it. Can you point me to a tutorial on how to do this, or give me some direction about this? Thanks!

Accepted Answer Pending Moderation
0
Votes
Undo

normally if you have installed 5.6 over another one  (5.3 for me) the install will rename the old version folder  something like MAMP_2020-01-29_11-28-40

Delete or rename  your current MAMP folder  -> MAMP_5.6 , rename MAMP_2020-01-29_11-28-40  -> MAMP

install 5.5 

 

5.5 works perfectly

Accepted Answer Pending Moderation
1
Votes
Undo

Cirke,

Thank you. Your suggestion was the right one regarding version 5.6! I had to revert to version 5.4 because I don't have 5.5 and it doesn't seem to be available on the MAMP site. In any case, once I got rid of v. 5.6 the localhost sites began behaving properly again. Thanks again!  A.

Accepted Answer Pending Moderation
0
Votes
Undo

Just to add in some more info from my experience.

 

I had exactly the same initial symptom. These seemed to deteriorate over time, rather than all at once but I can't browse to any of my local sites. It seemed to start degrading a short time after installing Catalina, though this may be coincidental as the OS versions mentioned in the post are different.

I'm not sure if it's related but I also find that the MAMP Pro window keeps freezing after maybe 1-2 changes (even stop & start a service) where I have to force quit.

In the MySQL logs for me I kept seeing this repeated:

[Warning] InnoDB: Table mysql/innodb_table_stats has length mismatch in the column name table_name. Please run mysql_upgrade

So, naturally, I ran it and it did its thing. After it finished I tried the sites again. Every single attempt shows the same thing in the MySQL log now (substituting the db name & user):

[Note] Aborted connection 86 to db: 'dbname' user: 'dbuser' host: 'localhost' (Got an error reading communication packets)

I tried some troubleshooting steps based on this error to no avail - disabling strict mode, increasing max allowed packets and max connections and even dumped all DBs and re-imported so that they refreshed. Yesterday I backed up my sites & DBs, ran through the uninstaller and deleted the MAMP Application directories. After re-installing and re-configuring all of my settings I'm back to the above "aborted connection" messages.

With many applications on Catalina additional permissions need to be set. I tried adding MAMP Pro to "Full Disk Access" and "Accessibility" but this made no difference.

As suggested by other users I tried downgrading to 5.5 (then upgraded to 5.5.1), which does indeed work so I'd like to thank those who recommended this and I look forward to MAMP's resolution.

Accepted Answer Pending Moderation
0
Votes
Undo

Awesome. Thank you for sharing the success 

Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSupportMod,

Since several people (at least) are experiencing this bug after they have upgraded to v. 5.6, is there a way to report it to the developers so it can be addressed in future updates?

Accepted Answer Pending Moderation
0
Votes
Undo

MAMPSupportMod,

Since several people (at least) are experiencing this bug after they have upgraded to v. 5.6, is there a way to report it to the developers so it can be addressed in future updates?

https://bugs.mamp.info/login_page.php?return=%2Fmy_view_page.php

Accepted Answer Pending Moderation
1
Votes
Undo

Can you guys tell me where you have been able to find versions of MAMP PRO v5.5 v5.4 and v5.3 ??

Accepted Answer Pending Moderation
0
Votes
Undo
Accepted Answer Pending Moderation
0
Votes
Undo

there is a version here https://www.macupdate.com/app/mac/24001/mamp-pro

I'm talking with MAMP support, it sounds like they might release previous versions of 5 on their site. Keep you posted.

Accepted Answer Pending Moderation
1
Votes
Undo

Same issue here with a fresh 5.6 Installation on my MAC with latest Catlina and running a typo3 Website using MySQL and PHP 7.3.9.

 

Vincent

Accepted Answer Pending Moderation
1
Votes
Undo

Hi!

I had the same issue with Joomla! after the update to MAMP PRO 5.6. After a lot of failed attempts to fix it, I've found an easy solution.

Go to PHP -> Mode -> switch to CGI Mode (I used the module mode before). Restart the server and Joomla! should work again without any issues with PHP 7.3 (PHP 7.4 also works but the core is not fully compatible with it yet).

Have success!

Viktor

Accepted Answer Pending Moderation
0
Votes
Undo
I can not change this setting. Maybe bcs I am using the free version?
Accepted Answer Pending Moderation
0
Votes
Undo

I had the same issue using WordPress and Mamp Pro 5.6 but after changing the PHP Mode to CGI Mode (as kubikrubik/Viktor suggested) the problem was fixed. Thank you!

 

My configuration:

macOS 10.15.3

Mamp Pro Version: 5.6

PHP Version: 7.3.9

WordPress 5.3.2

 

Julian

 

  • Page :
  • 1
  • 2


There are no replies made for this post yet.
Be one of the first to reply to this post!