1. Farmaworld
  2. MAMP - General Discussion
  3. Wednesday, 29 May 2019

in cd ext/pdo_firebird i run /Applications/MAMP/bin/php/php5.6.40/bin/phpize 


after 


./configure --with-pdo-firebird=/Library/Frameworks/Firebird.framework 


and i have error 


iMac:pdo_firebird raffaele$ /Applications/MAMP/bin/php/php5.6.40/bin/phpize 
Configuring for: 
PHP Api Version: 20131106 
Zend Module Api No: 20131226 
Zend Extension Api No: 220131226 
iMac:pdo_firebird raffaele$ ./configure --with-pdo-firebird=/Library/Frameworks/Firebird.framework 
checking for grep that handles long lines and -e... /usr/bin/grep 
checking for egrep... /usr/bin/grep -E 
checking for a sed that does not truncate output... /usr/local/bin/sed 
checking for cc... cc 
checking whether the C compiler works... yes 
checking for C compiler default output file name... a.out 
checking for suffix of executables... 
checking whether we are cross compiling... no 
checking for suffix of object files... o 
checking whether we are using the GNU C compiler... yes 
checking whether cc accepts -g... yes 
checking for cc option to accept ISO C89... none needed 
checking how to run the C preprocessor... cc -E 
checking for icc... no 
checking for suncc... no 
checking whether cc understands -c and -o together... yes 
checking for system library directory... lib 
checking if compiler supports -R... no 
checking if compiler supports -Wl,-rpath,... yes 
checking build system type... x86_64-apple-darwin18.5.0 
checking host system type... x86_64-apple-darwin18.5.0 
checking target system type... x86_64-apple-darwin18.5.0 
checking for PHP prefix... /usr 
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib 
checking for PHP extension directory... /usr/lib/php/extensions/no-debug-non-zts-20160303 
checking for PHP installed headers prefix... /usr/include/php 
checking if debug is enabled... no 
checking if zts is enabled... no 
checking for re2c... re2c 
checking for re2c version... 1.0.3 (ok) 
checking for gawk... no 
checking for nawk... no 
checking for awk... awk 
checking if awk is broken... no 
checking for Firebird support for PDO... yes, shared 
checking for isc_detach_database in -lfbclient... yes 
checking for PDO includes... checking for PDO includes... 
configure: error: Cannot find php_pdo_driver.h. 


why?





There are no replies made for this post yet.
Be one of the first to reply to this post!