1. halion
  2. MAMP - Troubleshooting
  3. Thursday, 05 December 2019

Dear all,

i did an Update from MAMP Pro 3.6 to 5.5. on Mac OS Catalina 10.15.1

 

unfortunately when i start MAMP Pro from Application folder after the new installation i get the an error message that it could not be started:

 

the following report is dumped:

Process: MAMP PRO [2737]
Path: /Applications/MAMP PRO.app/Contents/MacOS/MAMP PRO
Identifier: de.appsolute.mamppro
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: MAMP PRO [2737]
User ID: 501

Date/Time: 2019-12-06 00:00:32.647 +0100
OS Version: Mac OS X 10.15.1 (19B88)
Report Version: 12
Anonymous UUID: 6344F7B9-7D8C-32C3-165A-F83186E607B3

 

Time Awake Since Boot: 1600 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
-->
__TEXT 000000010c9b2000-000000010d217000 [ 8596K] r-x/rwx SM=COW

Thread 0 Crashed:
0 0x000000011c49c000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffee324dc40
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000011c49c000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

 

Binary Images:
0x10c9b2000 - 0x10d216fff + (0)
0x11c49b000 - 0x11c52bb5f + (733.6)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 135841
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=9.8M resident=0K(0%) swapped_out_or_unallocated=9.8M(100%)
Writable regions: Total=8420K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8420K(100%)

VIRTUAL REGION
REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
STACK GUARD 56.0M 1
Stack 8192K 1
__DATA 916K 4
__DATA_CONST 20K 1
__LINKEDIT 900K 3
__TEXT 9176K 2
shared memory 8K 2
=========== ======= =======
TOTAL 74.8M 14

 

 

 

Would be so cool to get help here?

best regards

Phil



Accepted Answer Pending Moderation
0
Votes
Undo

My worst fear shared by someone else. I'll take a close look later when I have more time. Assuming you can, did you try re-installing MAMP completely?

 

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!