1. ethan
  2. MAMP - Troubleshooting
  3. Thursday, 17 October 2019

You probably read the post title and are thinking to yourself, "wow another person with this issue that can't solve it using Google." Let me start by saying I've resolved these issues using other software like AMPPS before and am very familiar with downloading and setting up the latest certificate files. I cannot for the life of me get my cURL requests to work even though I have specified the proper certificate files in all the PHP configurations I can find.

I am running macOS Catalina with a near-fresh install of MAMP. I had to switch to MAMP when I updated my OS yesterday because AMPPS is not supported on Catalina. MAMP is configured to run PHP 7.3.8. Here's what I've done so far:

  1. Downloaded the latest CA file from https://curl.haxx.se/docs/caextract.html
  2. Replaced the cacert.pem file in my MAMP OpenSSL install: /Applications/MAMP/Library/OpenSSL/certs/cacert.pem
  3. Opened the two relevant php.ini files. One is located at /Applications/MAMP/conf/php7.3.8/php.ini and the other at /Applications/MAMP/bin/php/php7.3.8/conf/php.ini
  4. Added the URL to the new cacert.pem
    1. curl.cainfo = "/Applications/MAMP/Library/OpenSSL/certs/cacert.pem"
    2. openssl.cafile = "/Applications/MAMP/Library/OpenSSL/certs/cacert.pem"
    3. openssl.capath = "/Applications/MAMP/Library/OpenSSL/certs"
    4. I tried these configurations with and without the capath
  5. Checked phpinfo to ensure the paths were populating correctly. Both the OpenSSL paths and the curl paths were updated properly.
  6. STILL GET THIS ERROR
  7. I also tried moving the certificate file to other locations on my computer to no avail.

I am at a complete loss for what to try next. Please help!



Accepted Answer Pending Moderation
1
Votes
Undo

Turns out my company's internet security suite was somehow intercepting my requests and causing them to fail. Connected outside of the network and the cURL requests are working fine now. UGH

Accepted Answer Pending Moderation
0
Votes
Undo

Thanks for reporting back.

  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!