1. mark.bijl@validaide.com
  2. MAMP - Troubleshooting
  3. Tuesday, 20 October 2020

Hi everyone,

I just installed the latest version of MAMP PRO 6.0.1 and want to configure one of my hosts to use the HTTP2 protocol and not HTTP/1.1. The 'http2_module' is enabled (by default). My host is using a SSL file. I'm accessing it on HTTPS. I've added 'Protocols h2c' to the 'Additional Parameters' section of the host configuration. Restarted. But... according to my browser's developer tools, they're still 1.1 requests, not 2.0...

Did anyone try this yet? Any clues on what I might be missing?

Help much appreciated!
Thanks in advance,

Cheers,
Mark



Accepted Answer Pending Moderation
0
Votes
Undo

Hi everyone,

I just installed the latest version of MAMP PRO 6.0.1 and want to configure one of my hosts to use the HTTP2 protocol and not HTTP/1.1. The 'http2_module' is enabled (by default). My host is using a SSL file. I'm accessing it on HTTPS. I've added 'Protocols h2c' to the 'Additional Parameters' section of the host configuration. Restarted. But... according to my browser's developer tools, they're still 1.1 requests, not 2.0...

Did anyone try this yet? Any clues on what I might be missing?

Help much appreciated!
Thanks in advance,

Cheers,
Mark

I checked a few of my sites in v5 mamp, they are all using h2 and h3 in dev tools. I didn't need to enable or add anything special to the site either. Whats your site?
  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo

Hi, thanks for the quick response! I've got a Symfony 3.4 application running. Using Firefox Developer edition to check the HTTP protocol used. You're saying that out-of-the-box HTTP2 is enabled in MAMP PRO when I've enabled SSL in my host? I have the 'SSL' checkbox checked, accessing my site on port 8890... But according Firefox Developer it is getting HTTP/1.1 responses...

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo

So here is my curl output below. I created a host, enabled SSL, and my Apache SSL port is configured to 8890.

It just keeps on returning HTTP/1.1, no matter what I try... Are there any other dependencies that might be a problem?



bash$ curl -I -s --insecure --http2 https://validaide:8890

HTTP/1.1 200 OK
Date: Tue, 20 Oct 2020 15:51:42 GMT
Server: Apache/2.4.46 (Unix) OpenSSL/1.0.2u PHP/7.2.33 mod_wsgi/3.5 Python/2.7.13 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_perl/2.0.11 Perl/v5.30.1
X-Powered-By: PHP/7.2.33
Cache-Control: max-age=0, must-revalidate, private
Expires: Tue, 20 Oct 2020 15:51:42 GMT
Content-Type: text/html; charset=UTF-8

 

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo

MAMP PRO Version 6 includes mod_http2 but HTTP2 is still not supported with Apache from what I can see. With the module on and including "Protocols h2 h2c http/1.1" in the config it still doesn't work and the reason is because Apache is using the mpm_prefork module as shown in the error log when starting the server (http2 logging has to be on to show this):

AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.

MAMP Pro will have to use mpm_event instead of mpm_prefork and allow us to use PHP-FPM before HTTP2 will work. We can set our PHP Mode to CGI instead of Module and use Nginx for a specific host on port 443 but HTTP2 still doesn't work so even with version 6 we're still behind the times!

  1. more than a month ago
  2. MAMP - Troubleshooting
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!