1. acristancho
  2. MAMP - Troubleshooting
  3. Monday, 16 November 2020

I recently upgraded to MAMP PRO 6, and now my hosts set up for SSL will not load.  I read some of MAMP documentation and went so far as to delete the MAMP_PRO_Root_CA certificate in my macOS keychain. MAMP PRO immediately replaced the certificate, but this didn't fix the problem. I need https for certain hopes for QA purposes, so it's important. I am trying avoid uninstalling MAMP PRO and reinstalling it and having to rebuild all my hosts. Does anyone have any suggestions on how I can fix this? This is all occurring on an iMac (27-inch, Late 2013) running macOS Catalina 10.15.7.



Accepted Answer Pending Moderation
0
Votes
Undo

I'm having the same problem. I also tried several fixes, including deleting the MAMP_PRO_Root_CA certificate, changing the SSL certificate to "Allows Trust," reverting back to Mamp Pro 5 and the old Mamp folder. Both the server and database are running, but the error message is: 

This site can’t provide a secure connection

[Site name] sent an invalid response.

ERR_SSL_PROTOCOL_ERROR
 
Maybe it's something other than the SSL settings? Any help would be appreciated.
Accepted Answer Pending Moderation
0
Votes
Undo

Well, I figured it out and thought I'd post in case anyone else has the same problem. I realized (and this must have happened on upgrade to Mamp Pro 6 because everything worked fine before) that the host was using the default 8888 port for apache, despite having SSL. I changed the port numbers from the defaults to different values. This entailed changing the site url and home in wp_options of the database to agree with the new SSL port. Now everything works fine. Good luck!

  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!