1. pmenard
  2. MAMP - General Discussion
  3. Thursday, 05 November 2020

Upgrded this week from MAMP/MAMP Pro 5.7.x to MAMP 6.0.1. Since then I've been seeing the following in my /Applications/MAMP/logs/php_error.log

I've tried reinstalling the PHP 7.4.9 version. No luck.

I'm not even using this PHP version. I'm using PHP 7.4.10 as my default versions and this is used by all 6 of my sites. 

I've also enabled this PHP version then edited the php.ini and disabled the call to load this library. Restart MAMP and no luck. 

 

[05-Nov-2020 17:54:17 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'pgsql.so' (tried: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib

  Referenced from: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so

  Reason: image not found), /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so.so, 9): image not found)) in Unknown on line 0

 



Accepted Answer Pending Moderation
0
Votes
Undo

I am also getting this problem after updating to OSX Big Sur. I'm running MAMP Pro 5.3 and this particular host is using PHP 7.3.1

 

 

PHP Core Warning 'yii\base\ErrorException' with message 'PHP Startup: Unable to load dynamic library 'pdo_pgsql.so' (tried: /Applications/MAMP/bin/php/php7.3.1/lib/php/extensions/no-debug-non-zts-20180731/pdo_pgsql.so (dlopen(/Applications/MAMP/bin/php/php7.3.1/lib/php/extensions/no-debug-non-zts-20180731/pdo_pgsql.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib
Referenced from: /Applications/MAMP/bin/php/php7.3.1/lib/php/extensions/no-debug-non-zts-20180731/pdo_pgsql.so
Reason: image not found), /Applications/MAMP/bin/php/php7.3.1/lib/php/extensions/no-debug-non-zts-20180731/pdo_pgsql.so.so (dlopen(/Applications/MAMP/bin/php/php7.3.1/lib/php/extensions/no-debug-non-zts-20180731/pdo_pgsql.so.so, 9): image not found))'

Accepted Answer Pending Moderation
0
Votes
Undo

Run brew update 

Accepted Answer Pending Moderation
0
Votes
Undo

Run into the same problem. But if you can see here: 

pdo_pgsql.so.so

there is a typo at the .so extension. 

So, i've copied the pdo_pgsql.so and renamed it to pdo_pgsql.so.so. And it worked. 

Accepted Answer Pending Moderation
1
Votes
Undo

Gilles, I noticed that too. I would suggest making a symlink rather than renaming the file, just in case.

ln pdo_pgsql.so pdo_pgsql.so.so

brew update does seem to solve the problem though

Accepted Answer Pending Moderation
0
Votes
Undo

I'm having the exact same issue on Big Sur and MAMP 6. I've updated Homebrew to 2.5.11 and tried both copying and making a symlink of pdo_pgsql.so and still no go. Any other ideas?

Accepted Answer Pending Moderation
0
Votes
Undo

Hi together, 

 

after quite some trying I finally got mine running!

First I had to add the symlinks for the mistyped .so.so 

 

cd /Applications/MAMP/bin/php/php7.4.10/lib/php/extensions/no-debug-non-zts-20190902/

ln -s pgsql.so pgsql.so.so

ln -s pdo_pgsql.so pdo_pgsql.so.so

 

Then the startup-error message changed so I also needed to add another symlink:

cd /Applications/MAMP/Library/pg/lib

ln -s libpq.5.7.dylib libpq.5.dylib

 

Restart, up and running now!

Accepted Answer Pending Moderation
0
Votes
Undo

Hi, I tried symlinks etc. and nothing helps. Any ideas?

Accepted Answer Pending Moderation
0
Votes
Undo

Hiting same issue, even after adding the symlinks.

 

MacBook-Pro-15-inch-2018:~ sstankov$ php -v

 

Warning: PHP Startup: Unable to load dynamic library 'pgsql.so' (tried: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib

 

  Referenced from: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so

 

  Reason: image not found), /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib

 

  Referenced from: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pgsql.so.so

 

  Reason: image not found)) in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library 'pdo_pgsql.so' (tried: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib

 

  Referenced from: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so

 

  Reason: image not found), /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so.so (dlopen(/Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so.so, 9): Library not loaded: /Applications/MAMP/Library/pg/lib/libpq.5.dylib

 

  Referenced from: /Applications/MAMP/bin/php/php7.4.9/lib/php/extensions/no-debug-non-zts-20190902/pdo_pgsql.so.so

 

  Reason: image not found)) in Unknown on line 0

 

PHP 7.4.9 (cli) (built: Aug 31 2020 14:42:45) ( NTS )

 

Copyright (c) The PHP Group

 

Zend Engine v3.4.0, Copyright (c) Zend Technologies

 

    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans

Accepted Answer Pending Moderation
0
Votes
Undo

OK here is my update to whoever can help.

 

1. Updating brew does not seem to help;

2. Create symlinks for sure;

3. I needed to delete rm libpq.5.dylib, as it was pointing to some astray link; (I did not create it);

4. Create a symlink for it similar to what alohse said.

Accepted Answer Pending Moderation
0
Votes
Undo

Same problem here and none of the above helped. Did a clean install of Mamp 6.2 and still the same.

 

Edit: deleting libpq.5.dylib and re-creating the symlink, like sstankov said, helped. Thanks.

 
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!